[Python] Traducir codigo de Pseint

Topic created · 7 Posts · 9916 Views
  • Bueno, estoy empezando con esto del Python y mirando por ahi me ha dado por hacer una tonteria de codigo con Pseudocodigo que me es bastante mas facil y necesito que alguien me ayude a traducirlo al lenguaje normal.

    Proceso Repetir01
    Repetir
    Escribir "Escribe tu contraseña";
    Leer clave;
    Si clave <> 1234 Entonces
    Escribir "Clave incorrecta";
    FinSi
    Hasta Que clave=1234
    Escribir "Bienvenido!";
    Escribir "Introduce el numero del archivo"
    Leer numero
    Si numero=1 Entonces Escribir "Abriendo archivo numero 1"

    FinSi

    FinProceso

    Se que "Escribir" es Print si no me equivoco, If, Else etc pero aver si me podeis ayudar aunque sea una tonteria de codigo xD

  • Process Repetir01
    Repeat
    Print "Escribe tu contraseña";
    read clave;
    If clave <> 1234 Then
    Print "Clave incorrecta";
    EndIf
    Untill clave=1234
    Print "Bienvenido!";
    Print "Introduce el numero del archivo"
    Read numero
    If numero=1 Then
    print "Abriendo archivo numero 1"

    EndIf

    EndProcess

    Si no te va print, prueba "Write"
    Si no te va Untill, prueba "While"

  • Si entendí bien, pides el código Python correspondiente a ese código en Pseudocódigo no?
    En Python es :

    def Repetir01() :
    clave = 0
    while clave != 1234:
    clave = input("Escribe tu contrasena\n")
    if clave != 1234:
    print "Clave incorrecta"
    print "Bienvenido!"
    numero = input("Introduce el numero del archivo\n")
    if numero == 1:
    print "Abriendo archivo numero 1"
    if __name__ == "__main__" :
    Repetir01()

  • Gracias a los dos cuando vuelva de viaje os cuento que estoy en el movil

  • alguien me podria ayudar porfa necesito pasar esto a pseint :T.T:

    import getpass

    print "---- BIENVENIDO AL AHORCADO ----"
    print ""

    a = getpass.getpass("ingrese palabra secreta: ")
    aux=["_"]*len(a)
    print aux

    for i in range(7):
    letra = raw_input(">>")
    acerto = 0
    for j, l in enumerate(a):
    if l == letra:
    aux[j]=l
    acerto = 1
    if acerto:
    print "Bien!"
    else:
    print "Muy mal!"
    print aux
    if '_' not in aux:
    print "Lo lograste!"

    break
    if i == 6:
    print "era la palabra sigua participando",a

  • HOLA NECESITO QUE ALGUIEN ME AYUDE A PASAR ESTO A PSEINT POR FAVOR.

    from numpy import *
    n = input ("ingresar cantidad de usuarios")
    estaturas = zeros (n)
    nombres = chararray(n,itemsize=15)

    for i in range(n):
    nombres_= input("Ingresar nombre: ")
    estaturas_=input("Ingresar estaturas")
    print nombres, estaturas

    print "el de mayor estatura se llama" ,nombres[estaturas.argmax()], estaturas.max()
    print "el de menor estarura se llama" ,nombres[estaturas.argmin()], estaturas.min()

    print "el promedio de las estaturas es:" ,estaturas.mean()
    ma = 0
    me = 0
    for i in range(n) :
    if estaturas_>= estaturas.mean() :
    ma = ma+1

    else :
    me= me+1

    print "superaron el promedio",ma
    print "no superaron el promedio",me___

  • No te aconsejo el pseudocodigo salvo en problemas muy complejos, aunque si quieres aprenderlos bien, para resolver problemas serios te recomiendo el ide http://www.escuelapython.com/pycharm-uno-de-los-mejores-ide-para-python/ puedes desarrollar buen pseudo y ademas agregarle luego el código.

Log in to reply